#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<pre[^<]*>.*?<\/pre>(*SKIP)(*F)|\bASCII\b"
Local $sString = "<pre>Some" & @CRLF & _
"Test" & @CRLF & _
"ASCII" & @CRLF & _
"Text</pre>ASCII<pre>ASCII and another" & @CRLF & _
" line here</pre>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")