package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<pre[^<]*>.*?<\/pre>(*SKIP)(*F)|\bASCII\b`)
var str = `<pre>Some
Test
ASCII
Text</pre>ASCII<pre>ASCII and another
line here</pre>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}