$re = '/(?s)<pre[^<]*>.*?<\/pre>(*SKIP)(*F)|\bASCII\b/';
$str = '<pre>Some
Test
ASCII
Text</pre>ASCII<pre>ASCII and another
line here</pre>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);