import Foundation
let pattern = #"(?s)<pre[^<]*>.*?<\/pre>(*SKIP)(*F)|\bASCII\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<pre>Some
Test
ASCII
Text</pre>ASCII<pre>ASCII and another
line here</pre>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}