re = /(?s)<pre[^<]*>.*?<\/pre>(*SKIP)(*F)|\bASCII\b/
str = '<pre>Some
Test
ASCII
Text</pre>ASCII<pre>ASCII and another
line here</pre>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end