using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<pre[^<]*>.*?<\/pre>(*SKIP)(*F)|\bASCII\b";
string input = @"<pre>Some
Test
ASCII
Text</pre>ASCII<pre>ASCII and another
line here</pre>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}