import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<pre[^<]*>.*?<\\/pre>(*SKIP)(*F)|\\bASCII\\b";
final String string = "<pre>Some\n"
+ "Test\n"
+ "ASCII\n"
+ "Text</pre>ASCII<pre>ASCII and another\n"
+ " line here</pre>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}