#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*),("merchant_price":.*),(.*)"
Local $sString = "notice":true,"user_can_reopen_ticket":true,"recipient_id":"None","fulfillment_min_raw":1547416736,"status":"Shipped","fulfillment_max_yearless":"Feb 25","ticket_perm_closed":false,"merchant_price":1.0,"delivered""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")