import Foundation
let pattern = #"(.*),("merchant_price":.*),(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"notice":true,"user_can_reopen_ticket":true,"recipient_id":"None","fulfillment_min_raw":1547416736,"status":"Shipped","fulfillment_max_yearless":"Feb 25","ticket_perm_closed":false,"merchant_price":1.0,"delivered""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)