re = /(.*),("merchant_price":.*),(.*)/m
str = 'notice":true,"user_can_reopen_ticket":true,"recipient_id":"None","fulfillment_min_raw":1547416736,"status":"Shipped","fulfillment_max_yearless":"Feb 25","ticket_perm_closed":false,"merchant_price":1.0,"delivered"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end