$re = '/(.*),("merchant_price":.*),(.*)/m';
$str = 'notice":true,"user_can_reopen_ticket":true,"recipient_id":"None","fulfillment_min_raw":1547416736,"status":"Shipped","fulfillment_max_yearless":"Feb 25","ticket_perm_closed":false,"merchant_price":1.0,"delivered"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);