import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*),(\"merchant_price\":.*),(.*)";
final String string = "notice\":true,\"user_can_reopen_ticket\":true,\"recipient_id\":\"None\",\"fulfillment_min_raw\":1547416736,\"status\":\"Shipped\",\"fulfillment_max_yearless\":\"Feb 25\",\"ticket_perm_closed\":false,\"merchant_price\":1.0,\"delivered\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}