use strict;
my $str = 'notice":true,"user_can_reopen_ticket":true,"recipient_id":"None","fulfillment_min_raw":1547416736,"status":"Shipped","fulfillment_max_yearless":"Feb 25","ticket_perm_closed":false,"merchant_price":1.0,"delivered"';
my $regex = qr/(.*),("merchant_price":.*),(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}