using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(I*))(^\1|,\2I|\2I)+$";
string input = @"I,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII
II,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII
IIIIII,IIIIIII
III,IIII,IIIII,IIIIII";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}