const regex = /^(?=(I*))(^\1|,\2I|\2I)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(I*))(^\\1|,\\2I|\\2I)+$', 'gm')
const str = `I,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII
II,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII
IIIIII,IIIIIII
III,IIII,IIIII,IIIIII`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}