re = /^(?=(I*))(^\1|,\2I|\2I)+$/m
str = 'I,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII
II,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII
IIIIII,IIIIIII
III,IIII,IIIII,IIIIII'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end