import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(I*))(^\\1|,\\2I|\\2I)+$";
final String string = "I,II,III,IIII,IIIII,IIIIII,IIIIIII\n"
+ "I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII\n"
+ "II,II,III,IIII,IIIII,IIIIII,IIIIIII\n"
+ "I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII\n"
+ "IIIIII,IIIIIII\n"
+ "III,IIII,IIIII,IIIIII";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}