import re
regex = re.compile(r"^(?=(I*))(^\1|,\2I|\2I)+$", flags=re.MULTILINE)
test_str = ("I,II,III,IIII,IIIII,IIIIII,IIIIIII\n"
"I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII\n"
"II,II,III,IIII,IIIII,IIIIII,IIIIIII\n"
"I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII\n"
"IIIIII,IIIIIII\n"
"III,IIII,IIIII,IIIIII")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")