$re = '/^(?=(I*))(^\1|,\2I|\2I)+$/m';
$str = 'I,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII
II,II,III,IIII,IIIII,IIIIII,IIIIIII
I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII
IIIIII,IIIIIII
III,IIII,IIIII,IIIIII';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);