#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(-start|(?!^)\G)(.*?)FIND(?=.*end-)"
Local $sString = "somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-"
Local $sSubst = "$1$2NEW_WORD"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)