use strict;
my $str = 'somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-';
my $regex = qr/(-start|(?!^)\G)(.*?)FIND(?=.*end-)/p;
my $subst = '$1$2NEW_WORD';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";