import Foundation
let pattern = #"(-start|(?!^)\G)(.*?)FIND(?=.*end-)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2NEW_WORD"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)