using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-start|(?!^)\G)(.*?)FIND(?=.*end-)";
string substitution = @"$1$2NEW_WORD";
string input = @"somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}