const regex = /(-start|(?!^)\G)(.*?)FIND(?=.*end-)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-start|(?!^)\\G)(.*?)FIND(?=.*end-)', 'g')
const str = `somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-`;
const subst = `$1$2NEW_WORD`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);