re = /(-start|(?!^)\G)(.*?)FIND(?=.*end-)/
str = 'somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-'
subst = '$1$2NEW_WORD'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result