package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?msU)^[-]\s++(.+$.+$.+$)`)
var str = `- hallo welt
-- hello world
Saluton Mondo
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko - s dad
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
müll sd apodj9adj
müll sd apodj9adj
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}