const regex = /^[-]\s++(.+$.+$.+$)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-]\\s++(.+$.+$.+$)', 'gms')
const str = `- hallo welt
-- hello world
Saluton Mondo
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko - s dad
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
müll sd apodj9adj
müll sd apodj9adj
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}