// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?msU)^[-]\s++(.+$.+$.+$)").unwrap();
let string = "- hallo welt
-- hello world
Saluton Mondo
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko - s dad
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
müll sd apodj9adj
müll sd apodj9adj
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}