import re
regex = re.compile(r"^[-]\s++(.+$.+$.+$)", flags=re.MULTILINE | re.DOTALL)
test_str = ("- hallo welt\n"
"-- hello world\n"
"Saluton Mondo\n"
"- Bonjour tout le monde\n"
"Merhaba Dünya\n"
"-- moni Dziko\n"
"- Bonjour tout le monde \n"
" Merhaba Dünya\n"
" -- moni Dziko - s dad\n\n"
" müll sd apodj9adj \n\n"
"- Bonjour tout le monde\n"
"Merhaba Dünya\n"
"-- moni Dziko\n\n"
"müll sd apodj9adj \n\n"
" müll sd apodj9adj \n\n\n"
"müll sd apodj9adj \n\n"
"- Bonjour tout le monde\n"
"Merhaba Dünya\n"
"-- moni Dziko")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")