re = /^[-]\s++(.+$.+$.+$)/m
str = '- hallo welt
-- hello world
Saluton Mondo
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko - s dad
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
müll sd apodj9adj
müll sd apodj9adj
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end