import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-]\\s++(.+$.+$.+$)";
final String string = "- hallo welt\n"
+ "-- hello world\n"
+ "Saluton Mondo\n"
+ "- Bonjour tout le monde\n"
+ "Merhaba Dünya\n"
+ "-- moni Dziko\n"
+ "- Bonjour tout le monde \n"
+ " Merhaba Dünya\n"
+ " -- moni Dziko - s dad\n\n"
+ " müll sd apodj9adj \n\n"
+ "- Bonjour tout le monde\n"
+ "Merhaba Dünya\n"
+ "-- moni Dziko\n\n"
+ "müll sd apodj9adj \n\n"
+ " müll sd apodj9adj \n\n\n"
+ "müll sd apodj9adj \n\n"
+ "- Bonjour tout le monde\n"
+ "Merhaba Dünya\n"
+ "-- moni Dziko";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}