#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=source:\s)\S+(?:\s+\S+){3,7}\b"
Local $sString = "source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;" & @CRLF & _
"source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake" & @CRLF & _
"source: Leafy green vegetables such as spinach; egg yolks; liver" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")