import re
regex = re.compile(r"(?<=source:\s)\S+(?:\s+\S+){3,7}\b", flags=re.MULTILINE)
test_str = ("source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;\n"
"source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake\n"
"source: Leafy green vegetables such as spinach; egg yolks; liver\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")