import Foundation
let pattern = #"(?<=source:\s)\S+(?:\s+\S+){3,7}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;
source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake
source: Leafy green vegetables such as spinach; egg yolks; liver
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)