$re = '/(?<=source:\s)\S+(?:\s+\S+){3,7}\b/m';
$str = 'source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;
source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake
source: Leafy green vegetables such as spinach; egg yolks; liver
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);