use strict;
my $str = 'source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;
source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake
source: Leafy green vegetables such as spinach; egg yolks; liver
';
my $regex = qr/(?<=source:\s)\S+(?:\s+\S+){3,7}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}