using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=source:\s)\S+(?:\s+\S+){3,7}\b";
string input = @"source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;
source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake
source: Leafy green vegetables such as spinach; egg yolks; liver
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}