import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=source:\\s)\\S+(?:\\s+\\S+){3,7}\\b";
final String string = "source: from animal origin as Vitamin A / all-trans-Retinol: Fish in general, liver and dairy products;\n"
+ "source: Eggs, liver, certain fish species such as sardines, certain mushroom species such as shiitake\n"
+ "source: Leafy green vegetables such as spinach; egg yolks; liver\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}