#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.\d+(*SKIP)(*FAIL)|\B(?=(?:\d{3})+(?!\d))"
Local $sString = "123456789.1" & @CRLF & _
"123456789" & @CRLF & _
"1.1" & @CRLF & _
"10.1" & @CRLF & _
"100.1" & @CRLF & _
"1000.1" & @CRLF & _
"10000.11" & @CRLF & _
"100000.1111111111" & @CRLF & _
"1000000.111" & @CRLF & _
"10000000.11111.1111" & @CRLF & _
"100000000.111111" & @CRLF & _
"1000000000.1111111" & @CRLF & _
"" & @CRLF & _
"123456789" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1000" & @CRLF & _
"10000" & @CRLF & _
"100000" & @CRLF & _
"1000000" & @CRLF & _
"10000000" & @CRLF & _
"100000000" & @CRLF & _
"1000000000"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)