# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.\d+(*SKIP)(*FAIL)|\B(?=(?:\d{3})+(?!\d))"
test_str = ("123456789.1\n"
"123456789\n"
"1.1\n"
"10.1\n"
"100.1\n"
"1000.1\n"
"10000.11\n"
"100000.1111111111\n"
"1000000.111\n"
"10000000.11111.1111\n"
"100000000.111111\n"
"1000000000.1111111\n\n"
"123456789\n"
"1\n"
"10\n"
"100\n"
"1000\n"
"10000\n"
"100000\n"
"1000000\n"
"10000000\n"
"100000000\n"
"1000000000")
subst = ","
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.