import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.\\d+(*SKIP)(*FAIL)|\\B(?=(?:\\d{3})+(?!\\d))";
final String string = "123456789.1\n"
+ "123456789\n"
+ "1.1\n"
+ "10.1\n"
+ "100.1\n"
+ "1000.1\n"
+ "10000.11\n"
+ "100000.1111111111\n"
+ "1000000.111\n"
+ "10000000.11111.1111\n"
+ "100000000.111111\n"
+ "1000000000.1111111\n\n"
+ "123456789\n"
+ "1\n"
+ "10\n"
+ "100\n"
+ "1000\n"
+ "10000\n"
+ "100000\n"
+ "1000000\n"
+ "10000000\n"
+ "100000000\n"
+ "1000000000";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}