$re = '/\.\d+(*SKIP)(*FAIL)|\B(?=(?:\d{3})+(?!\d))/m';
$str = '123456789.1
123456789
1.1
10.1
100.1
1000.1
10000.11
100000.1111111111
1000000.111
10000000.11111.1111
100000000.111111
1000000000.1111111
123456789
1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;