import Foundation
let pattern = #"\.\d+(*SKIP)(*FAIL)|\B(?=(?:\d{3})+(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123456789.1
123456789
1.1
10.1
100.1
1000.1
10000.11
100000.1111111111
1000000.111
10000000.11111.1111
100000000.111111
1000000000.1111111
123456789
1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)