#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+(?:[\.,](?![\.,])\d+)*)"
Local $sString = "1,23...233" & @CRLF & _
"" & @CRLF & _
".8.8,0" & @CRLF & _
",9..9,9" & @CRLF & _
"6,234" & @CRLF & _
"1234" & @CRLF & _
"1,234" & @CRLF & _
"1,234.00" & @CRLF & _
"1234..00" & @CRLF & _
"1,234,456.789" & @CRLF & _
"1,2345hgf456...789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")