import Foundation
let pattern = #"(\d+(?:[\.,](?![\.,])\d+)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1,23...233
.8.8,0
,9..9,9
6,234
1234
1,234
1,234.00
1234..00
1,234,456.789
1,2345hgf456...789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)