$re = '/(\d+(?:[\.,](?![\.,])\d+)*)/';
$str = '1,23...233
.8.8,0
,9..9,9
6,234
1234
1,234
1,234.00
1234..00
1,234,456.789
1,2345hgf456...789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);