using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:[\.,](?![\.,])\d+)*)";
string input = @"1,23...233
.8.8,0
,9..9,9
6,234
1234
1,234
1,234.00
1234..00
1,234,456.789
1,2345hgf456...789";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}