import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(?:[\\.,](?![\\.,])\\d+)*)";
final String string = "1,23...233\n\n"
+ ".8.8,0\n"
+ ",9..9,9\n"
+ "6,234\n"
+ "1234\n"
+ "1,234\n"
+ "1,234.00\n"
+ "1234..00\n"
+ "1,234,456.789\n"
+ "1,2345hgf456...789";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}