import re
regex = re.compile(r"(\d+(?:[\.,](?![\.,])\d+)*)")
test_str = ("1,23...233\n\n"
".8.8,0\n"
",9..9,9\n"
"6,234\n"
"1234\n"
"1,234\n"
"1,234.00\n"
"1234..00\n"
"1,234,456.789\n"
"1,2345hgf456...789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")