#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<link.*href=['"]([^'"]*).*|<script.*src=['"]([^'"]*).*)"
Local $sString = "<link rel="stylesheet" type="text/css" href="/BLAH/Test/Test/Test.css">" & @CRLF & _
"<script src="/blah/Test/Test/Test.js"></script> " & @CRLF & _
"<link href="/BLAH/Test/Test/Test.css" xx="dfasf">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")